AppPage.net

Screenshots

  • Nexge C5 screenshot 1
  • Nexge C5 screenshot 2
  • Nexge C5 screenshot 3
  • Nexge C5 screenshot 4

About Nexge C5

Nexge MobileApp for FTTH Users: VoIP Mobile Application for FTTH(Fiber To the Home) users to facilitae users to initiate and receive calls.It facilitates to make ONNNET(Users in FTTH network) and OFFNET(calls through Service Provider) calls. Also to enable them to use the following Class 5 Features: 1. Call Wait 2. Call Hold 3. Call Transfer 4. Caller ID Block 5. Outgoing call Bar 6. Incoming call Block 7. Call Forward(Unconditional, Busy, No response) 8. Speed Dial It also enables them to subscribe and unsubscribe for the above Class 5 feautres. The above MobileApp is custom built for the FTTH(Fiber To The Home) users. MobileApp will get installed on the Mobile after getting it authenticated through OTP on user's existing FTTH Landline Number. The following are the features: 1. SIP RFC 3261 Compliant 2. RTP RFC 3550 Compliant 3. Supports DTMF based on RFC 2833 4. Integrated with Subscriber Management Server for presenting Balance and Class 5 Provisioning 5. Stores Call History locally 6. Supports Native Phone Book 7. Supports attended and Un-attended call transfer 8. Supports 3 party conference, split, and swap on two connected calls

What’s new

Version 2.5 · Updated August 14, 2026

Bug fixes and improvements

App privacy

The developer, Nexge Technologies Private Limited, reported these privacy practices to Apple.

Data Not Linked to You

The following data, which may be collected but is not linked to your identity, may be used for the following purposes:

  • Contacts: Contacts
  • Identifiers: User ID, Device ID

Used for: App Functionality

Alternatives to Nexge C5

Looking for apps like Nexge C5? Here are 6 similar apps on the App Store. The highest rated is SnapCard - OTM BLTM Event App (5.0/5), and all 6 are free to download.

Nexge C5 vs. alternatives
App Rating Price Last updated Compare
Nexge C5 – Free August 14, 2026
inCarCall – Free May 6, 2026 Compare
YunGO International Calls – Free Jun 25, 2024 Compare
SDB: One – Free Aug 11, 2026 Compare
Messenger Web for WhatsApp 4.8 / 5 (6) Free Jun 12, 2025 Compare
Nabour – Free Sep 11, 2026 Compare
SnapCard - OTM BLTM Event App 5.0 / 5 (1) Free Feb 22, 2026 Compare

Compare Nexge C5 with the top alternatives: ratings, updates, ASO score and keyword gaps →